aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..e9c35a4
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,23 @@
1{
2 inputs = {
3 nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.05";
4 flake-utils.url = "github:numtide/flake-utils";
5 };
6
7 outputs = { self, nixpkgs, flake-utils, ... }:
8 flake-utils.lib.eachDefaultSystem (system:
9 let
10 pkgs = import nixpkgs { inherit system; };
11 in
12 {
13 devShells.default = with pkgs; mkShell {
14 buildInputs = [
15 coqPackages.coqide
16 coqPackages.stdpp
17 coq
18 ];
19 };
20
21 formatter = pkgs.nixpkgs-fmt;
22 });
23}