aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libtmi8/flake.nix
diff options
context:
space:
mode:
authorLibravatar Rutger Broekhoff2024-05-02 20:27:40 +0200
committerLibravatar Rutger Broekhoff2024-05-02 20:27:40 +0200
commit17a3ea880402338420699e03bcb24181e4ff3924 (patch)
treeda666ef91e0b60d20aa0b01529644c136fd1f4ab /lib/libtmi8/flake.nix
downloadoeuf-17a3ea880402338420699e03bcb24181e4ff3924.tar.gz
oeuf-17a3ea880402338420699e03bcb24181e4ff3924.zip
Initial commit
Based on dc4ba6a
Diffstat (limited to 'lib/libtmi8/flake.nix')
-rw-r--r--lib/libtmi8/flake.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/lib/libtmi8/flake.nix b/lib/libtmi8/flake.nix
new file mode 100644
index 0000000..2ae7fc9
--- /dev/null
+++ b/lib/libtmi8/flake.nix
@@ -0,0 +1,42 @@
1{
2 inputs = {
3 nixpkgs.url = "https://flakehub.com/f/NixOs/nixpkgs/*.tar.gz";
4 flake-utils.url = "https://flakehub.com/f/numtide/flake-utils/0.1.88.tar.gz";
5 };
6
7 outputs = { self, nixpkgs, flake-utils, ... }@inputs:
8 flake-utils.lib.eachDefaultSystem
9 (system:
10 let
11 pkgs = import nixpkgs {
12 inherit system;
13 overlays = [ ];
14 };
15
16 inherit (pkgs.gcc13) stdenv;
17
18 oeuf-libtmi8 = stdenv.mkDerivation {
19 name = "oeuf-libtmi8";
20 src = pkgs.lib.cleanSource ./.;
21
22 nativeBuildInputs = with pkgs; [ gcc13 ];
23 buildInputs = with pkgs; [ arrow-cpp boost182 ];
24 buildPhase = ''
25 make libtmi8
26 '';
27
28 installPhase = ''
29 make install DESTDIR="$out"
30 '';
31 };
32 in
33 {
34 packages.oeuf-libtmi8 = oeuf-libtmi8;
35
36 devShells.default = pkgs.mkShell {
37 inputsFrom = [ oeuf-libtmi8 ];
38 };
39
40 formatter = pkgs.nixpkgs-fmt;
41 });
42}