aboutsummaryrefslogtreecommitdiffstats
path: root/script/archiver/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'script/archiver/default.nix')
-rw-r--r--script/archiver/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/script/archiver/default.nix b/script/archiver/default.nix
new file mode 100644
index 0000000..4a464e0
--- /dev/null
+++ b/script/archiver/default.nix
@@ -0,0 +1,15 @@
1{ pkgs ? import <nixpkgs> { } }: with pkgs;
2
3stdenv.mkDerivation {
4 name = "oeuf-archiver";
5 src = ./.;
6
7 buildInputs = [ bash rclone oeuf-bundleparquet ];
8 nativeBuildInputs = [ makeWrapper ];
9 installPhase = ''
10 mkdir -p $out/bin
11 cp oeuf-archiver.sh $out/bin/oeuf-archiver
12 wrapProgram $out/bin/oeuf-archiver \
13 --prefix PATH : ${lib.makeBinPath [ bash rclone oeuf-bundleparquet ]}
14 '';
15}