aboutsummaryrefslogtreecommitdiffstats
path: root/rs/server/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar Rutger Broekhoff2024-01-19 01:53:04 +0100
committerLibravatar Rutger Broekhoff2024-01-19 01:53:04 +0100
commitfa2a763777d775a853ec41d73efb345e304c81e7 (patch)
tree0735621337ee93e41e00a0d52fbdabff93b9e8fc /rs/server/Cargo.toml
parent5156228f18f08255a1f5c7e22097b8e367881e19 (diff)
downloadgitolfs3-fa2a763777d775a853ec41d73efb345e304c81e7.tar.gz
gitolfs3-fa2a763777d775a853ec41d73efb345e304c81e7.zip
Separate path rewrite into Tower Layer, shared state for S3 client
Diffstat (limited to 'rs/server/Cargo.toml')
-rw-r--r--rs/server/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/rs/server/Cargo.toml b/rs/server/Cargo.toml
index ac571af..188299a 100644
--- a/rs/server/Cargo.toml
+++ b/rs/server/Cargo.toml
@@ -4,12 +4,15 @@ version = "0.1.0"
4edition = "2021" 4edition = "2021"
5 5
6[dependencies] 6[dependencies]
7aws-config = { version = "1.1.2", features = ["behavior-version-latest"] }
8aws-sdk-s3 = "1.12.0"
7axum = "0.7" 9axum = "0.7"
8aws-creds = "0.34" 10aws-creds = "0.34"
11base64 = "0.21"
9chrono = { version = "0.4", features = ["serde"] } 12chrono = { version = "0.4", features = ["serde"] }
10common = { path = "../common" } 13common = { path = "../common" }
11mime = "0.3" 14mime = "0.3"
12rust-s3 = "0.33"
13serde = { version = "1", features = ["derive"] } 15serde = { version = "1", features = ["derive"] }
14tokio = { version = "1.35", features = ["full"] } 16tokio = { version = "1.35", features = ["full"] }
17tower = "0.4"
15tower-service = "0.3" 18tower-service = "0.3"